NONMEM Users Network Archive

Hosted by Cognigen

A weird problem in $TABLE output when using nonmem 7.4.3 with MPI

From: Cris Zhang <xzhang511>
Date: Tue, 3 Nov 2020 18:01:57 +0800

Hi all,

Glad to join the community recently. I ran into a weird problem in $TABLE
output when I was running a PopPK model using nonmem 7.4.3 with MPI: a few
values of the first record (such as ID, EVID, CMT, TIME) erroneously come
from the last individual in the output table (see Table 1 and Table 2
below).

Table 1. Example of the first few rows of $TABLE output when running NONMEM
with mpi
TABLE NO. 1
STUDY ID PT EVID CMT TIME DV TSLD DOSEMG IV FED WTKG TVCL TVVC TVVP1 TVQ1
TVVP2
3.10E+03 9.27E+02 5.27E+06 1.00E+00 2.00E+00 0.00E+00 0.00E+00 0.00E+00
6.00E+02 0.00E+00 0.00E+00 7.00E+01 1.34E+02 4.62E+01 5.40E+02 8.63E+01
2.59E+02
1.01E+03 7.90E+01 1.00E+06 0.00E+00 1.00E+00 1.02E+00 1.99E+00 1.02E+00
1.50E+02 1.00E+00 1.00E+00 6.14E+01 1.34E+02 4.62E+01 5.40E+02 8.63E+01
2.59E+02
1.01E+03 7.90E+01 1.00E+06 0.00E+00 1.00E+00 1.25E+00 1.16E+00 1.25E+00
1.50E+02 1.00E+00 1.00E+00 6.14E+01 1.34E+02 4.62E+01 5.40E+02 8.63E+01
2.59E+02
1.01E+03 7.90E+01 1.00E+06 0.00E+00 1.00E+00 1.50E+00 8.38E-01 1.50E+00
1.50E+02 1.00E+00 1.00E+00 6.14E+01 1.34E+02 4.62E+01 5.40E+02 8.63E+01
2.59E+02


Table 2. Example of the last few rows of $TABLE output when running NONMEM
with mpi
TABLE NO. 1
STUDY ID PT EVID CMT TIME DV TSLD DOSEMG IV FED WTKG TVCL TVVC TVVP1 TVQ1
TVVP2
3.10E+03 9.27E+02 5.27E+06 1.00E+00 2.00E+00 0.00E+00 0.00E+00 0.00E+00
6.00E+02 0.00E+00 0.00E+00 7.00E+01 8.98E+01 4.62E+01 2.23E+02 4.07E+01
2.59E+02
3.10E+03 9.27E+02 5.27E+06 1.00E+00 5.00E+00 0.00E+00 0.00E+00 0.00E+00
6.00E+02 0.00E+00 0.00E+00 7.00E+01 8.98E+01 4.62E+01 2.23E+02 4.07E+01
2.59E+02
3.10E+03 9.27E+02 5.27E+06 0.00E+00 1.00E+00 1.15E+00 7.82E-01 1.15E+00
6.00E+02 0.00E+00 0.00E+00 7.00E+01 8.98E+01 4.62E+01 2.23E+02 4.07E+01
2.59E+02
3.10E+03 9.27E+02 5.27E+06 0.00E+00 1.00E+00 3.08E+00 1.63E+00 3.08E+00
6.00E+02 0.00E+00 0.00E+00 7.00E+01 8.98E+01 4.62E+01 2.23E+02 4.07E+01
2.59E+02

Interestingly, there is no such problem when I run the model without MPI
(see Table 3 below).

Table 3. Example of the first few rows of $TABLE output when running NONMEM
without mpi
TABLE NO. 1
STUDY ID PT EVID CMT TIME DV TSLD DOSEMG IV FED WTKG TVCL TVVC TVVP1 TVQ1
TVVP2
1.01E+03 7.90E+01 1.00E+06 1.00E+00 1.00E+00 0.00E+00 0.00E+00 0.00E+00
1.50E+02 1.00E+00 1.00E+00 6.14E+01 1.34E+02 4.62E+01 5.40E+02 8.63E+01
2.59E+02
1.01E+03 7.90E+01 1.00E+06 0.00E+00 1.00E+00 1.02E+00 1.99E+00 1.02E+00
1.50E+02 1.00E+00 1.00E+00 6.14E+01 1.34E+02 4.62E+01 5.40E+02 8.63E+01
2.59E+02
1.01E+03 7.90E+01 1.00E+06 0.00E+00 1.00E+00 1.25E+00 1.16E+00 1.25E+00
1.50E+02 1.00E+00 1.00E+00 6.14E+01 1.34E+02 4.62E+01 5.40E+02 8.63E+01
2.59E+02
1.01E+03 7.90E+01 1.00E+06 0.00E+00 1.00E+00 1.50E+00 8.38E-01 1.50E+00
1.50E+02 1.00E+00 1.00E+00 6.14E+01 1.34E+02 4.62E+01 5.40E+02 8.63E+01
2.59E+02


Have anyone ever encountered the same problem? What could possibly the
reason for the problem before? And how can I avoid such a problem?


Thanks in advance!

Best regards,
Cris Zhang
Sinovant Sciences

Received on Tue Nov 03 2020 - 05:01:57 EST

The NONMEM Users Network is maintained by ICON plc. Requests to subscribe to the network should be sent to: nmusers-request@iconplc.com.

Once subscribed, you may contribute to the discussion by emailing: nmusers@globomaxnm.com.