Re: [NMusers] Incomplete circles drawn in VPC plotted using R scripts generated by PsN

From: Kajsa Harling <kajsa.harling_at_farmbio.uu.se>
Date: Fri, 20 Nov 2015 11:33:17 +0100
Dear Matthew,

I suggest you consult the xpose.VPC documentation ( ?xpose.VPC() ) for instructions on how to change how values are marked in the plot. The PsN -rplots script uses the default settings.

Best regards,
Kajsa

On 11/19/2015 03:56 PM, HUI, Ka Ho wrote:

Dear all,

 

I was trying to generate VPC using the R scripts generated by PsN with the following command line:

 

vpc

-samples=200

-stratify_on=…

-rplots=1

-idv=TIME

-auto_bin=unique

-predcorr

-varcorr

-dir=vpc_FINAL_MODEL

FINAL_MODEL_vpc.mod

 

The R script generated looks like this:

 

#START OF AUTO-GENERATED PREAMBLE, WILL BE OVERWRITTEN WHEN THIS FILE IS USED AS A TEMPLATE

#Created 2015-11-19 at 22:05

 

rplots.level <- 1

xpose.runno <- '1_vpc'

toolname <- 'vpc'

pdf.filename <- paste0('PsN_',toolname,'_plots.pdf')

pdf.title <- 'vpc diagnostic plots run 1_vpc'

working.directory<-'C:/…'

raw.results.file <- 'raw_results_FINAL_MODEL1_vpc.csv'

model.directory<-'C:/…'

model.filename<-'FINAL_MODEL1_vpc.mod'

subset.variable<-NULL

mod.suffix <- '.mod'

mod.prefix <- 'FINAL_MODEL'

tab.suffix <- ''

tool.results.file <- 'vpc_results.csv'

theta.labels <- c('T1','T2','T3','T4','T5','T6')

theta.fixed <- c(FALSE,FALSE,TRUE,FALSE,FALSE,FALSE)

omega.labels <- c('O1','O2')

omega.fixed <- c(FALSE,FALSE)

sigma.labels <- c('S1')

sigma.fixed <- c(FALSE)

n.eta <- 2

n.eps <- 1

 

vpctab <- 'vpctab'

have.loq.data <- FALSE

have.censored <- FALSE

is.categorical <- FALSE

is.tte <- FALSE

dv <- 'DV'

idv <- 'TIME2'

 

setwd(working.directory)

 

############################################################################

#END OF AUTO-GENERATED PREAMBLE

#WHEN THIS FILE IS USED AS A TEMPLATE THIS LINE MUST LOOK EXACTLY LIKE THIS

 

 

library(xpose4)

 

pdf(file=pdf.filename,width=10,height=7,title=pdf.title)

 

done <- FALSE

if (is.tte){

     #data is in the model directory, go there to read input

        setwd(model.directory)

        xpdb <- xpose.data(xpose.runno)

        plots <- kaplan.plot(object=xpdb,VPC=T)

        #go back to vpc directory

        setwd(working.directory)

        done <- TRUE

 

if (is.categorical & (!done)){

    plots<-xpose.VPC.categorical(vpc.info=tool.results.file,vpctab=vpctab)

        done <- TRUE

}

 

if ((have.loq.data | have.censored) & (!done) ){

    plots<-xpose.VPC.both(vpc.info=tool.results.file,vpctab=vpctab)

        done <- TRUE

}

 

if (!done){

        plots<-xpose.VPC(vpc.info=tool.results.file,vpctab=vpctab)

        done <- TRUE

}

 

print(plots)

 

dev.off()

 

However the “circles” (indicating raw Cp data) are incomplete and take the shape of a “crescent moon” instead. When run with the –lloq option, the 1st stratification has complete circles but the remaining 2 also has the crescent-moon circles instead. Other parts of the plots (Shades and plots of CI) look normal.

Can anyone suggest any possible cause and solution?

 

Thanks and regards,

Matthew Hui


-- 
-----------------------------------------------------------------
Kajsa Harling, PhD
System Developer
Department of Pharmaceutical Biosciences
Uppsala University

Kajsa.Harling_at_farmbio.uu.se
+46-(0)18-471 4308

http://www.farmbio.uu.se/research/researchgroups/pharmacometrics/
-----------------------------------------------------------------
Received on Fri Nov 20 2015 - 05:33:17 EST

This archive was generated by hypermail 2.3.0 : Fri Sep 27 2019 - 16:47:13 EDT