RE: [NMusers] Error in LSODA: Code -5

From: Andre Jackson <jacksonan1945_at_gmail.com>
Date: Thu, 10 Dec 2015 15:22:00 -0500

Leonid:

I tried the first suggestion by getting rid of some of the data that was
deficient (i.e., subjects with less than 8 concentrations over the 30 hr.
sampling period) and the LSODA error was not present.

I will also try your other suggestions sequentially to see if they also
improve the analysis.

Thanks for your input.

Andre

-----Original Message-----
From: Leonid Gibiansky [mailto:lgibiansky_at_quantpharm.com]
Sent: Thursday, December 10, 2015 9:59 AM
To: Andre Jackson; nmusers_at_globomaxnm.com
Subject: Re: [NMusers] Error in LSODA: Code -5

Usually this error message is not informative: it just tells you that
something is wrong with the model. It can be fixed by (in the order of
importance)
- cleaning the data (look on concentration-time plots to remove obvious
outliers),
- starting with the better initial parameter values (e.g., your mean
analysis final estimates),
- setting bounds on THETAs,
- removing some ETAs,
- using combined residual error instead of the purely proportional one,
- using residual error with ETAs (instead of Y=IPRED*(1+W*EPS()) use
Y=IPRED(1+W*EXP(ETA())*EPS()),
- other model modifications/simplifications/improvements, including changing
the estimation method (try FO if nothing helps, and then used FO final
estimates to start something more advanced)

Leonid



--------------------------------------
Leonid Gibiansky, Ph.D.
President, QuantPharm LLC
web: www.quantpharm.com
e-mail: LGibiansky at quantpharm.com
tel: (301) 767 5566



On 12/10/2015 8:10 AM, Andre Jackson wrote:
> I have run a control stream that runs okay following MU modeling with
> the mean data to establish the best structural model using NM7 with
> ADVAN 13 TRANS1 TOL=6.
>
> However when I attempt to run the model in a population mode with even
> one eta on a MU I get the following error.
>
> OCCURS DURING SEARCH FOR ETA AT INITIAL VALUE, ETA=0
>
> ERROR IN LSODA: CODE -5
>
> ERROR OCURRED WHILE ATTEMPTING TO OBTAIN INITIAL VALUES FOR ATOL
>
> 0PROGRAM TERMINATED BY OBJ
>
> I have seen some posts in the archives on LSODA and differential
> equations but nothing that seems to address my problem directly.
>
> Does anyone know of any more definitive posts or have suggestions as to
> how best to proceed.
>
> Thanks
>
> Andre Jackson
>
> Jacksonan1945_at_Gmail.com <mailto:Jacksonan1945_at_Gmail.com>
>

Received on Thu Dec 10 2015 - 15:22:00 EST

This archive was generated by hypermail 2.3.0 : Fri Sep 27 2019 - 16:47:54 EDT